CVE-2024-1597 is a critical-severity (CVSS 10) SQL Injection vulnerability in org.postgresql:postgresql. A fix is available for org.postgresql:postgresql — see the affected versions and patch details below.
pgjdbc SQL Injection via line comment generation
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-1597.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.postgresql:postgresql☕org.postgresql:postgresql☕org.postgresql:postgresql☕org.postgresql:postgresql☕org.postgresql:postgresql☕org.postgresql:postgresqlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
SQL injection is possible when using the non-default connection property preferQueryMode=simple in combination with application code that has a vulnerable SQL that negates a parameter value.
There is no vulnerability in the driver when using the default query mode. Users that do not override the query mode are not impacted.
Exploitation
To exploit this behavior the following conditions must be met:
- A placeholder for a numeric value must be immediately preceded by a minus (i.e.
-) - There must be a second placeholder for a string value after the first placeholder on the same line.
- Both parameters must be user controlled.
The prior behavior of the driver when operating in simple query mode would inline the negative value of the first parameter and cause the resulting line to be treated as a -- SQL comment. That would extend to the beginning of the next parameter and cause the quoting of that parameter to be consumed by the comment line. If that string parameter includes a newline, the resulting text would appear unescaped in the resulting SQL.
When operating in the default extended query mode this would not be an issue as the parameter values are sent separately to the server. Only in simple query mode the parameter values are inlined into the executed SQL causing this issue.
Example
PreparedStatement stmt = conn.prepareStatement("SELECT -?, ?");
stmt.setInt(1, -1);
stmt.setString(2, "\nWHERE false --");
ResultSet rs = stmt.executeQuery();
The resulting SQL when operating in simple query mode would be:
SELECT --1,'
WHERE false --'
The contents of the second parameter get injected into the command. Note how both the number of result columns and the WHERE clause of the command have changed. A more elaborate example could execute arbitrary other SQL commands.
Patch
Problem will be patched upgrade to 42.7.2, 42.6.1, 42.5.5, 42.4.4, 42.3.9, 42.2.28, 42.2.28.jre7
The patch fixes the inlining of parameters by forcing them all to be serialized as wrapped literals. The SQL in the prior example would be transformed into:
SELECT -('-1'::int4), ('
WHERE false --')
Workarounds
Do not use the connection propertypreferQueryMode=simple. (NOTE: If you do not explicitly specify a query mode then you are using the default of extended and are not impacted by this issue.)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.postgresql:postgresql | all versions | 42.2.28org.postgresql:postgresql:42.2.28 |
| ☕Maven | org.postgresql:postgresql | ≥ 42.3.0&&< 42.3.9 | 42.3.9org.postgresql:postgresql:42.3.9 |
| ☕Maven | org.postgresql:postgresql | ≥ 42.4.0&&< 42.4.4 | 42.4.4org.postgresql:postgresql:42.4.4 |
| ☕Maven | org.postgresql:postgresql | ≥ 42.5.0&&< 42.5.5 | 42.5.5org.postgresql:postgresql:42.5.5 |
| ☕Maven | org.postgresql:postgresql | ≥ 42.6.0&&< 42.6.1 | 42.6.1org.postgresql:postgresql:42.6.1 |
| ☕Maven | org.postgresql:postgresql | ≥ 42.7.0&&< 42.7.2 | 42.7.2org.postgresql:postgresql:42.7.2 |
Affected Products
fedorafedoraprojectpostgresql jdbc driverpostgresqlDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.postgresql:postgresql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.postgresql:postgresql to 42.2.28 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-1597 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The PostgreSQL JDBC Driver is not affected in the default query mode. Users that do not override the query mode are not impacted. The described SQL injection vulnerability, while significant, is categorized as important rather than critical due to several factors. Firstly, the exploitation relies on specific…
Do not use the connection propertypreferQueryMode=simple. If you do not explicitly specify a query mode, then you are using the default of extended and are not impacted by this issue.Source: Red Hat security advisory for CVE-2024-1597 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat build of Apache Camel 4.4.1 for Spring Boot 3.2 | pgjdbc | RHSA-2024:4884 |
| Red Hat build of Keycloak 24 | pgjdbc | RHBA-2024:2108 |
| Red Hat build of Quarkus 2.13.9.SP2 | org.postgresql/postgresql:42.5.6.redhat-00001 | RHSA-2024:1797 |
| Red Hat build of Quarkus 3.2.11.Final | org.postgresql/postgresql:42.6.1.redhat-00001 | RHSA-2024:1662 |
| Red Hat Enterprise Linux 8 | postgresql-jdbc-0:42.2.14-3.el8_9 | RHSA-2024:1435 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support | postgresql-jdbc-0:42.2.3-5.el8_2 | RHSA-2024:2624 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | postgresql-jdbc-0:42.2.3-7.el8_4 | RHSA-2024:4375 |
| Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support | postgresql-jdbc-0:42.2.3-5.el8_6 | RHSA-2024:4402 |
Frequently Asked Questions
Is CVE-2024-1597 in your dependencies?
Find it across Maven, including transitive dependencies.