phpMyAdmin vulnerable to Cross-site ScriptingGHSA-6q2j-8h8q-46mr
MEDIUMFix: phpmyadmin/phpmyadmin@03f73d4GHSA-6q2j-8h8q-46mr is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.4.x before 4.4.15.7 and 4.6.x before 4.6.3 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) server-privileges certificate data fields on the user privileges page, (2) an "invalid JSON" error message in the error console, (3) a database name in the central columns implementation, (4) a group name, or (5) a search name in the bookmarks implementation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.4.0&&< 4.4.15.7 | 4.4.15.7composer require phpmyadmin/phpmyadmin:^4.4.15.7 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.6.0&&< 4.6.3 | 4.6.3composer require phpmyadmin/phpmyadmin:^4.6.3 |
Affected Products
leapopensuseopensuseopensusephpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 4.4.15.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6q2j-8h8q-46mr is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-6q2j-8h8q-46mr in your dependencies?
Find it across Packagist, including transitive dependencies.