Cross-site Scripting in Jenkins JUnit PluginGHSA-64mj-3p92-589v
HIGHFix: jenkinsci/junit-plugin@c43d0fcGHSA-64mj-3p92-589v is a high-severity (CVSS 8) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:junit. EPSS puts its 30-day exploitation probability at 77.5% (100th percentile). A fix is available for org.jenkins-ci.plugins:junit — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jenkins-ci.plugins:junitReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
JUnit Plugin 1119.va_a_5e9068da_d7 and earlier does not escape descriptions of test results.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.
JUnit Plugin 1119.1121.vc43d0fc45561 applies the configured markup formatter to descriptions of test results.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jenkins-ci.plugins:junit | all versions | 1119.1121.vc43d0fc45561org.jenkins-ci.plugins:junit:1119.1121.vc43d0fc45561 |
Affected Products
junitjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:junit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jenkins-ci.plugins:junit to 1119.1121.vc43d0fc45561 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-64mj-3p92-589v is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.10 | jenkins-2-plugins-0:4.10.1663147786-1.el8 | RHSA-2022:6531 |
| Red Hat OpenShift Container Platform 4.8 | jenkins-2-plugins-0:4.8.1672842762-1.el8 | RHSA-2023:0017 |
| Red Hat OpenShift Container Platform 4.9 | jenkins-2-plugins-0:4.9.1667460322-1.el8 | RHBA-2022:8582 |
Frequently Asked Questions
Is GHSA-64mj-3p92-589v in your dependencies?
Find it across Maven, including transitive dependencies.