NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-34176 — junit

MEDIUMFix: jenkinsci/junit-plugin@c43d0fc

CVE-2022-34176 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:junit. EPSS puts its 30-day exploitation probability at 77.5% (100th percentile). A fix is available for org.jenkins-ci.plugins:junit — see the affected versions and patch details below.

Cross-site Scripting in Jenkins JUnit Plugin

Also known asGHSA-64mj-3p92-589v
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
77.5%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
33.4%51.5%69.6%87.7%56.0%77.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:junit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

JUnit Plugin 1119.va_a_5e9068da_d7 and earlier does not escape descriptions of test results.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.

JUnit Plugin 1119.1121.vc43d0fc45561 applies the configured markup formatter to descriptions of test results.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:junitall versions1119.1121.vc43d0fc45561org.jenkins-ci.plugins:junit:1119.1121.vc43d0fc45561

Affected Products

1 product · 1 configurations
Application
junitjenkins
≤ 1119.va_a_5e9068da_d7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:junit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:junit to 1119.1121.vc43d0fc45561 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-34176 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 4.10jenkins-2-plugins-0:4.10.1663147786-1.el8RHSA-2022:6531
Red Hat OpenShift Container Platform 4.8jenkins-2-plugins-0:4.8.1672842762-1.el8RHSA-2023:0017
Red Hat OpenShift Container Platform 4.9jenkins-2-plugins-0:4.9.1667460322-1.el8RHBA-2022:8582

Frequently Asked Questions

JUnit Plugin 1119.va_a_5e9068da_d7 and earlier does not escape descriptions of test results. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission. JUnit Plugin 1119.1121.vc43d0fc45561 applies the configured markup formatter to descriptions of test results.
O3 Security · Impact-Aware SCA

Is CVE-2022-34176 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-34176: junit XSS — Fix Available