NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Moderate severity vulnerability that affects mayan-edmsGHSA-5r76-cjf4-c9qx

MEDIUM

GHSA-5r76-cjf4-c9qx is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in mayan-edms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mayan-edms — see the affected versions and patch details below.

Also known asCVE-2018-16406PYSEC-2018-14
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.23%1.84%0.3%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mayan-edms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Mayan EDMS before 3.0.2. The Cabinets app has XSS via a crafted cabinet label.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImayan-edmsall versions3.0.2pip install --upgrade 'mayan-edms==3.0.2'

Affected Products

1 product · 1 configurations
Application
mayan edmsmayan-edms
< 3.0.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mayan-edms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mayan-edms to 3.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5r76-cjf4-c9qx is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in Mayan EDMS before 3.0.2. The Cabinets app has XSS via a crafted cabinet label.
O3 Security · Impact-Aware SCA

Is GHSA-5r76-cjf4-c9qx in your dependencies?

Find it across PyPI, including transitive dependencies.

Moderate severity vulnerability that affects mayan-edms