NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-47419 — mayan-edms

MEDIUM

CVE-2022-47419 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in mayan-edms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mayan-edms — see the affected versions and patch details below.

Mayan EDMS Tag XSS

Also known asGHSA-5m6v-2xgf-qhrwPYSEC-2023-276
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-47419.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.3%0.5%May 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mayan-edms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An XSS vulnerability was discovered in the Mayan EDMS DMS. Successful XSS exploitation was observed in the in-product tagging system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImayan-edmsall versions4.3.6pip install --upgrade 'mayan-edms==4.3.6'

Affected Products

1 product · 1 configurations
Application
mayan edmsmayan-edms
1 version
4.3.3
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mayan-edms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mayan-edms to 4.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-47419 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An XSS vulnerability was discovered in the Mayan EDMS DMS. Successful XSS exploitation was observed in the in-product tagging system.
O3 Security · Impact-Aware SCA

Is CVE-2022-47419 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-47419: mayan-edms XSS — Fixed in 4.3.6