phpMyAdmin allows remote attackers to spoof content via the url parameterGHSA-5pmg-qh2c-7j24
Fix: phpmyadmin/phpmyadmin@2b31866GHSA-5pmg-qh2c-7j24 is a CWE-254 vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The redirection feature in url.php in phpMyAdmin 4.4.x before 4.4.15.1 and 4.5.x before 4.5.1 allows remote attackers to spoof content via the url parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.4.0&&< 4.4.15.1 | 4.4.15.1composer require phpmyadmin/phpmyadmin:^4.4.15.1 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.5.0&&< 4.5.1 | 4.5.1composer require phpmyadmin/phpmyadmin:^4.5.1 |
Affected Products
phpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 4.4.15.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5pmg-qh2c-7j24 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-5pmg-qh2c-7j24 in your dependencies?
Find it across Packagist, including transitive dependencies.