NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Improper Neutralization of Input During Web Page Generation Apache ActiveMQGHSA-5jg4-p78r-p5j3

MEDIUMFix: apache/activemq@77b827f

GHSA-5jg4-p78r-p5j3 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.activemq:activemq-client. A fix is available for org.apache.activemq:activemq-client — see the affected versions and patch details below.

Also known asCVE-2016-6810
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
1.99%3.67%5.36%7.04%2.9%6.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.activemq:activemq-client

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:activemq-client≥ 5.0.0&&< 5.14.25.14.2org.apache.activemq:activemq-client:5.14.2

Affected Products

1 product · 1 configurations
Application
activemqapache
≥ 5.0.0 && < 5.14.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:activemq-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:activemq-client to 5.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5jg4-p78r-p5j3 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present in the web based administration console. The root cause of this issue is improper user data output validation.
O3 Security · Impact-Aware SCA

Is GHSA-5jg4-p78r-p5j3 in your dependencies?

Find it across Maven, including transitive dependencies.

Improper Neutralization of Input During Web Page…