NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Missing Authorization in Apache ArchivaGHSA-5hqc-x78w-3cmw

MEDIUM

GHSA-5hqc-x78w-3cmw is a medium-severity (CVSS 6.5) vulnerability in org.apache.archiva:archiva. A fix is available for org.apache.archiva:archiva — see the affected versions and patch details below.

Also known asCVE-2022-29405
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.76%1.25%1.74%2.22%1.3%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.archiva:archiva

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Archiva, any registered user can reset password for any users. This is fixed in Archiva 2.2.8.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.archiva:archivaall versions2.2.8org.apache.archiva:archiva:2.2.8

Affected Products

1 product · 1 configurations
Application
archivaapache
< 2.2.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.archiva:archiva, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.archiva:archiva to 2.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5hqc-x78w-3cmw is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Apache Archiva, any registered user can reset password for any users. This is fixed in Archiva 2.2.8.
O3 Security · Impact-Aware SCA

Is GHSA-5hqc-x78w-3cmw in your dependencies?

Find it across Maven, including transitive dependencies.

Missing Authorization in Apache Archiva (Medium 6.5)