SilverStripe Folders migrated from 3.x may be unsafe to upload toGHSA-592m-4533-rxq9
HIGHFix: silverstripe/silverstripe-assets@6779fd3GHSA-592m-4533-rxq9 is a high-severity (CVSS 7.5) Unrestricted File Upload vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
silverstripe/framework🐘silverstripe/userforms🐘silverstripe/assets🐘silverstripe/assetsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In SilverStripe through 4.5, files uploaded via Forms to folders migrated from Silverstripe CMS 3.x may be put to the default "/Uploads" folder instead. This affects installations which allowed upload folder protection via the optional silverstripe/secureassets module under 3.x. This module is installed and enabled by default on the Common Web Platform (CWP). The vulnerability only affects files uploaded after an upgrade to 4.x.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 4.0.0&&< 4.4.6 | 4.4.6composer require silverstripe/framework:^4.4.6 |
| 🐘Packagist | silverstripe/userforms | ≥ 5.0.0&&< 5.4.2 | 5.4.2composer require silverstripe/userforms:^5.4.2 |
| 🐘Packagist | silverstripe/assets | ≥ 1.0.0&&< 1.4.7 | 1.4.7composer require silverstripe/assets:^1.4.7 |
| 🐘Packagist | silverstripe/assets | ≥ 1.5.0&&< 1.5.2 | 1.5.2composer require silverstripe/assets:^1.5.2 |
Affected Products
silverstripesilverstripeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 4.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-592m-4533-rxq9 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is GHSA-592m-4533-rxq9 in your dependencies?
Find it across Packagist, including transitive dependencies.