Silverstripe Framework user enumeration via timing attack on login and password reset formsGHSA-256q-hx8w-xcqx
MEDIUMFix: silverstripe/silverstripe-framework#11681GHSA-256q-hx8w-xcqx is a medium-severity (CVSS 5.3) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Real-World Exposure
silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
User enumeration is possible by performing a timing attack on the login or password reset pages with user credentials.
This was originally disclosed in https://www.silverstripe.org/download/security-releases/ss-2017-005/ for CMS 3 but was not patched in CMS 4+
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 4.0.0&&< 5.3.23 | 5.3.23composer require silverstripe/framework:^5.3.23 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 5.3.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-256q-hx8w-xcqx is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-256q-hx8w-xcqx in your dependencies?
Find it across Packagist, including transitive dependencies.