NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2020-9280 — framework

HIGHFix: silverstripe/silverstripe-assets@6779fd3

CVE-2020-9280 is a high-severity (CVSS 7.5) Unrestricted File Upload vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.

SilverStripe Folders migrated from 3.x may be unsafe to upload to

Also known asBIT-silverstripe-2020-9280GHSA-592m-4533-rxq9
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.74%1.49%2.23%0.4%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘silverstripe/framework🐘silverstripe/userforms🐘silverstripe/assets🐘silverstripe/assets

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In SilverStripe through 4.5, files uploaded via Forms to folders migrated from Silverstripe CMS 3.x may be put to the default "/Uploads" folder instead. This affects installations which allowed upload folder protection via the optional silverstripe/secureassets module under 3.x. This module is installed and enabled by default on the Common Web Platform (CWP). The vulnerability only affects files uploaded after an upgrade to 4.x.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/framework≥ 4.0.0&&< 4.4.64.4.6composer require silverstripe/framework:^4.4.6
🐘Packagistsilverstripe/userforms≥ 5.0.0&&< 5.4.25.4.2composer require silverstripe/userforms:^5.4.2
🐘Packagistsilverstripe/assets≥ 1.0.0&&< 1.4.71.4.7composer require silverstripe/assets:^1.4.7
🐘Packagistsilverstripe/assets≥ 1.5.0&&< 1.5.21.5.2composer require silverstripe/assets:^1.5.2

Affected Products

1 product · 1 configurations
Application
silverstripesilverstripe
≥ 4.0.0 && ≤ 4.5.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/framework to 4.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-9280 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

Frequently Asked Questions

In SilverStripe through 4.5, files uploaded via Forms to folders migrated from Silverstripe CMS 3.x may be put to the default "/Uploads" folder instead. This affects installations which allowed upload folder protection via the optional silverstripe/secureassets module under 3.x. This module is installed and enabled by default on the Common Web Platform (CWP). The vulnerability only affects files uploaded after an upgrade to 4.x.
O3 Security · Impact-Aware SCA

Is CVE-2020-9280 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-9280: framework — Fixed in 4.4.6