phpMyAdmin Authentication BypassGHSA-567r-vqj7-5cw7
CRITICALGHSA-567r-vqj7-5cw7 is a critical-severity (CVSS 9.8) CWE-254 vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in phpMyAdmin involving the $cfg['ArbitraryServerRegexp'] configuration directive. An attacker could reuse certain cookie values in a way of bypassing the servers defined by ArbitraryServerRegexp. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.6&&< 4.6.4 | 4.6.4composer require phpmyadmin/phpmyadmin:^4.6.4 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.4&&< 4.4.15.8 | 4.4.15.8composer require phpmyadmin/phpmyadmin:^4.4.15.8 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.0&&< 4.0.10.17 | 4.0.10.17composer require phpmyadmin/phpmyadmin:^4.0.10.17 |
Affected Products
phpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 4.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-567r-vqj7-5cw7 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-567r-vqj7-5cw7 in your dependencies?
Find it across Packagist, including transitive dependencies.