GHSA-4p24-vmcr-4gqj is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars:bootstrap. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.webjars:bootstrap — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
bootstrapnpmDescription
In Bootstrap 2.x from 2.0.4, 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute. Note that this is a different vulnerability than CVE-2018-14041.
See https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0/ for more info.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.webjars:bootstrap | ≥ 2.0.4&&< 3.4.0 | 3.4.0org.webjars:bootstrap:3.4.0 |
| ☕Maven | org.webjars:bootstrap | ≥ 4.0.0-beta&&< 4.0.0-beta.2 | 4.0.0-beta.2org.webjars:bootstrap:4.0.0-beta.2 |
| 📦npm | bootstrap | ≥ 2.0.4&&< 3.4.0 | 3.4.0npm install bootstrap@3.4.0 |
| 📦npm | bootstrap | ≥ 4.0.0-beta&&< 4.0.0-beta.2 | 4.0.0-beta.2npm install bootstrap@4.0.0-beta.2 |
| 📦npm | bootstrap-sass | ≥ 2.0.4&&< 3.4.0 | 3.4.0npm install bootstrap-sass@3.4.0 |
| .NETNuGet | bootstrap | ≥ 2.0.4&&< 3.4.0 | 3.4.0dotnet add package bootstrap --version 3.4.0 |
Affected Products
bootstrapgetbootstrapResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars:bootstrap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.webjars:bootstrap to 3.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4p24-vmcr-4gqj is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Enterprise Satellite 5 is now in Maintenance Support 2 phase of the support and maintenance life cycle. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Red Hat Satellite 5 Life Cycle: https://access.redhat.com/support/policy/updates/satellite. Red…
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms Management Engine 5.11 | ansible-runner-0:1.3.4-2.el8ar | RHBA-2019:4199 |
| Red Hat Decision Manager 7 | bootstrap | RHSA-2020:0133 |
| Red Hat Enterprise Linux 7 | ipa-0:4.6.8-5.el7 | RHSA-2020:3936 |
| Red Hat Enterprise Linux 8 | idm:client-8030020200923172426.05ac3f11 | RHSA-2020:4670 |
| Red Hat Enterprise Linux 8 | pki-core:10.6-8030020200911215836.5ff1562f | RHSA-2020:4847 |
| Red Hat JBoss Enterprise Application Platform 7.4.9 | org.jboss.hal/hal-console:3.3.16.Final-redhat-00001 | RHSA-2023:0556 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el8eap | RHSA-2023:0553 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9 | eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el9eap | RHSA-2023:0554 |
Frequently Asked Questions
Is GHSA-4p24-vmcr-4gqj in your dependencies?
Find it across Maven, npm, NuGet, including transitive dependencies.