NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

get-npm-package-version Command Injection vulnerabilityGHSA-4h66-vghf-xg5x

CRITICALFix: hoperyy/get-npm-package-version@40b1cf3

GHSA-4h66-vghf-xg5x is a critical-severity (CVSS 9.8) CWE-77 vulnerability in get-npm-package-version. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for get-npm-package-version — see the affected versions and patch details below.

Also known asCVE-2020-7795
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
3.19%3.71%4.24%4.77%4.3%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

19other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
get-npm-package-versionnpm
301downloads / week

Description

The package get-npm-package-version before 1.0.7 is vulnerable to Command Injection via the main function in index.js.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmget-npm-package-versionall versions1.0.7npm install get-npm-package-version@1.0.7

Affected Products

1 product · 1 configurations
Application
get-npm-package-versionget-npm-package-version_project
< 1.0.7
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for get-npm-package-version, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update get-npm-package-version to 1.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4h66-vghf-xg5x is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The package get-npm-package-version before 1.0.7 is vulnerable to Command Injection via the `main` function in index.js.
O3 Security · Impact-Aware SCA

Is GHSA-4h66-vghf-xg5x in your dependencies?

Find it across npm, including transitive dependencies.

get-npm-package-version Command Injection vulnerability