NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

elFinder Path Traversal vulnerabilityGHSA-45x3-mw7q-wf7f

CRITICALFix: Studio-42/elFinder@157f471

GHSA-45x3-mw7q-wf7f is a critical-severity (CVSS 9.1) Path Traversal vulnerability in studio-42/elfinder. A fix is available for studio-42/elfinder — see the affected versions and patch details below.

Also known asCVE-2018-9109
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.21%1.34%2.47%3.60%0.8%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘studio-42/elfinder

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Studio 42 elFinder before 2.1.36 has a directory traversal vulnerability in elFinder.class.php with the zipdl() function that can allow a remote attacker to download files accessible by the web server process and delete files owned by the account running the web server process.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagiststudio-42/elfinderall versions2.1.36composer require studio-42/elfinder:^2.1.36

Affected Products

1 product · 1 configurations
Application
elfinderstd42
< 2.1.36
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for studio-42/elfinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update studio-42/elfinder to 2.1.36 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-45x3-mw7q-wf7f is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Studio 42 elFinder before 2.1.36 has a directory traversal vulnerability in `elFinder.class.php` with the `zipdl()` function that can allow a remote attacker to download files accessible by the web server process and delete files owned by the account running the web server process.
O3 Security · Impact-Aware SCA

Is GHSA-45x3-mw7q-wf7f in your dependencies?

Find it across Packagist, including transitive dependencies.

elFinder Path Traversal vulnerability (Critical 9.1)