CVE-2019-6257 is a high-severity (CVSS 7.7) Server-Side Request Forgery (SSRF) vulnerability in studio-42/elfinder. A fix is available for studio-42/elfinder — see the affected versions and patch details below.
elFinder Server Side Request Forgery (SSRF)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
studio-42/elfinderReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A Server Side Request Forgery (SSRF) vulnerability in elFinder before 2.1.46 could allow a malicious user to access the content of internal network resources. This occurs in get_remote_contents() in php/elFinder.class.php.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | studio-42/elfinder | all versions | 2.1.49composer require studio-42/elfinder:^2.1.49 |
Affected Products
elfinderstd42Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for studio-42/elfinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update studio-42/elfinder to 2.1.49 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-6257 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2019-6257 in your dependencies?
Find it across Packagist, including transitive dependencies.