NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-35840 — elfinder

MEDIUMFix: Studio-42/elFinder@bb9aaa7

CVE-2023-35840 is a medium-severity (CVSS 6.5) Path Traversal vulnerability in studio-42/elfinder. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for studio-42/elfinder — see the affected versions and patch details below.

elFinder vulnerable to path traversal in LocalVolumeDriver connector

Also known asGHSA-wm5g-p99q-66g4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-35840.

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.64%2.95%5.25%7.56%6.3%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘studio-42/elfinder

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Path Traversal vulnerability in PHP LocalVolumeDriver connector. This vulnerability can be exploited by allowing untrusted users to write to the local file system.

This issue was caused by incomplete validity checking of the supplied request parameters. That problem has been fixed in elFinder Version 2.1.62.

Patches

This vulnerability has been fixed in elFinder 2.1.62. Installation managers should update to the latest version as soon as possible.

Workarounds

If you cannot update for some reason, you must stop using it or prohibit writing to untrusted users.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagiststudio-42/elfinderall versions2.1.62composer require studio-42/elfinder:^2.1.62

Affected Products

1 product · 1 configurations
Application
elfinderstd42
< 2.1.62
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for studio-42/elfinder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update studio-42/elfinder to 2.1.62 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-35840 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact Path Traversal vulnerability in PHP LocalVolumeDriver connector. This vulnerability can be exploited by allowing untrusted users to write to the local file system. This issue was caused by incomplete validity checking of the supplied request parameters. That problem has been fixed in elFinder Version 2.1.62. ### Patches This vulnerability has been fixed in elFinder 2.1.62. Installation managers should update to the latest version as soon as possible. ### Workarounds If you cannot update for some reason, you must stop using it or prohibit writing to untrusted users.
O3 Security · Impact-Aware SCA

Is CVE-2023-35840 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-35840: elfinder Path Traversal — Fixed in 2.1.62