Improper Access Control in Apache DerbyGHSA-42xw-p62x-hwcf
MEDIUMGHSA-42xw-p62x-hwcf is a medium-severity (CVSS 5.3) vulnerability in org.apache.derby:derby. A fix is available for org.apache.derby:derby — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.derby:derbyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Derby 10.3.1.4 to 10.14.1.0, a specially-crafted network packet can be used to request the Derby Network Server to boot a database whose location and contents are under the user's control. If the Derby Network Server is not running with a Java Security Manager policy file, the attack is successful. If the server is using a policy file, the policy file must permit the database location to be read for the attack to work. The default Derby Network Server policy file distributed with the affected releases includes a permissive policy as the default Network Server policy, which allows the attack to work.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.derby:derby | ≥ 10.3.1.4&&< 10.14.2.0 | 10.14.2.0org.apache.derby:derby:10.14.2.0 |
Affected Products
derbyapacheweblogic serveroracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.derby:derby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.derby:derby to 10.14.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-42xw-p62x-hwcf is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-42xw-p62x-hwcf in your dependencies?
Find it across Maven, including transitive dependencies.