NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Grails data binding causes JVM crash and/or other denial of serviceGHSA-3pjv-r7w4-2cf5

MEDIUMFix: grails/grails-core@74326bd

GHSA-3pjv-r7w4-2cf5 is a medium-severity (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in org.grails:grails-databinding. A fix is available for org.grails:grails-databinding — see the affected versions and patch details below.

Also known asCVE-2023-46131
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.04%0.44%0.83%1.22%0.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.grails:grails-databinding☕org.grails:grails-databinding☕org.grails:grails-databinding☕org.grails:grails-databinding

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable.

Patches

Patches are available for Grails 3 and later.

Workarounds

No workaround is possible except to avoid data binding to request data.

References

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.grails:grails-databinding≥ 6.0.0&&< 6.1.06.1.0org.grails:grails-databinding:6.1.0
☕Mavenorg.grails:grails-databinding≥ 5.0.0&&< 5.3.45.3.4org.grails:grails-databinding:5.3.4
☕Mavenorg.grails:grails-databinding≥ 4.0.0&&< 4.1.34.1.3org.grails:grails-databinding:4.1.3
☕Mavenorg.grails:grails-databinding≥ 2.0.0&&< 3.3.173.3.17org.grails:grails-databinding:3.3.17

Affected Products

1 product · 4 configurations
Application
grailsgrails
≥ 6.0.0 && < 6.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.grails:grails-databinding, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.grails:grails-databinding to 6.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3pjv-r7w4-2cf5 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. ### Patches Patches are available for Grails 3 and later. ### Workarounds No workaround is possible except to avoid data binding to request data. ### References - [Blog post](https://grails.org/blog/2023-12-20-cve-data-binding-dos.html) - [Discussion](https://github.com/grails/grails-core/issues/13302) - [Mitre CVD record](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-46131)
O3 Security · Impact-Aware SCA

Is GHSA-3pjv-r7w4-2cf5 in your dependencies?

Find it across Maven, including transitive dependencies.

Grails data binding causes JVM crash and/or other denial…