CVE-2023-46131 is a medium-severity (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in org.grails:grails-databinding. A fix is available for org.grails:grails-databinding — see the affected versions and patch details below.
Grails® data binding causes JVM crash and/or DoS
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.grails:grails-databinding☕org.grails:grails-databinding☕org.grails:grails-databinding☕org.grails:grails-databindingReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable.
Patches
Patches are available for Grails 3 and later.
Workarounds
No workaround is possible except to avoid data binding to request data.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.grails:grails-databinding | ≥ 6.0.0&&< 6.1.0 | 6.1.0org.grails:grails-databinding:6.1.0 |
| ☕Maven | org.grails:grails-databinding | ≥ 5.0.0&&< 5.3.4 | 5.3.4org.grails:grails-databinding:5.3.4 |
| ☕Maven | org.grails:grails-databinding | ≥ 4.0.0&&< 4.1.3 | 4.1.3org.grails:grails-databinding:4.1.3 |
| ☕Maven | org.grails:grails-databinding | ≥ 2.0.0&&< 3.3.17 | 3.3.17org.grails:grails-databinding:3.3.17 |
Affected Products
grailsgrailsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.grails:grails-databinding, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.grails:grails-databinding to 6.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-46131 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2023-46131 in your dependencies?
Find it across Maven, including transitive dependencies.