CVE-2022-35912 — grails-databinding
CRITICALCVE-2022-35912 is a critical-severity (CVSS 9.8) remote code execution vulnerability in org.grails:grails-databinding. A fix is available for org.grails:grails-databinding — see the affected versions and patch details below.
Grails framework Remote Code Execution via Data Binding
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.grails:grails-databinding☕org.grails:grails-databinding☕org.grails:grails-databinding☕org.grails:grails-databindingReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability has been discovered in the Grails data-binding logic which allows for Remote Code Execution in a Grails application. This exploit requires the application to be running on Java 8, either deployed as a WAR to a servlet container, or an executable JAR.
Patches
Grails framework versions 5.2.1, 5.1.9, 4.1.1, and 3.3.15
References
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-35912 https://grails.org/blog/2022-07-18-rce-vulnerability.html
For more information
If you have any questions or comments about this advisory:
- https://grails.org/blog/2022-07-18-rce-vulnerability.html
- https://github.com/grails/grails-core/issues/12626
- Email us at [email protected]
Credit
This vulnerability was discovered by meizjm3i and codeplutos of AntGroup FG Security Lab
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.grails:grails-databinding | ≥ 3.3.10&&< 3.3.15 | 3.3.15org.grails:grails-databinding:3.3.15 |
| ☕Maven | org.grails:grails-databinding | ≥ 4.0.0&&< 4.1.1 | 4.1.1org.grails:grails-databinding:4.1.1 |
| ☕Maven | org.grails:grails-databinding | ≥ 5.0.0&&< 5.1.9 | 5.1.9org.grails:grails-databinding:5.1.9 |
| ☕Maven | org.grails:grails-databinding | ≥ 5.2.0&&< 5.2.1 | 5.2.1org.grails:grails-databinding:5.2.1 |
Affected Products
grailsgrailsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.grails:grails-databinding, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.grails:grails-databinding to 3.3.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35912 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-35912 in your dependencies?
Find it across Maven, including transitive dependencies.