NATS has mTLS verify_and_map authentication bypass via incorrect Subject DN matchingGHSA-3f24-pcvm-5jqc
MEDIUMGHSA-3f24-pcvm-5jqc is a medium-severity (CVSS 4.2) Improper Authentication vulnerability in github.com/nats-io/nats-server/v2. A fix is available for github.com/nats-io/nats-server/v2 — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-3f24-pcvm-5jqc.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/nats-io/nats-server/v2🐹github.com/nats-io/nats-server/v2🐹github.com/nats-io/nats-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Background
NATS.io is a high performance open source pub-sub distributed communication technology, built for the cloud, on-premise, IoT, and edge computing.
One authentication model supported is mTLS, deriving the NATS client identity from properties of the TLS Client Certificate.
Problem Description
When using mTLS for client identity, with verify_and_map to derive a NATS identity from the client certificate's Subject DN, certain patterns of RDN would not be correctly enforced, allowing for authentication bypass.
This does require a valid certificate from a CA already trusted for client certificates, and DN naming patterns which the NATS maintainers consider highly unlikely.
So this is an unlikely attack. Nonetheless, administrators who have been very sophisticated in their DN construction patterns might conceivably be impacted.
Affected Versions
Fixed in nats-server 2.12.6 & 2.11.15
Workarounds
Developers should review their CA issuing practices.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/nats-io/nats-server/v2 | all versions | 2.11.15go get github.com/nats-io/nats-server/v2@v2.11.15 |
| 🐹Go | github.com/nats-io/nats-server/v2 | ≥ 2.12.0-RC.1&&< 2.12.6 | 2.12.6go get github.com/nats-io/nats-server/v2@v2.12.6 |
| 🐹Go | github.com/nats-io/nats-server | all versions | No fix |
Affected Products
nats-serverlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/nats-io/nats-server/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/nats-io/nats-server/v2 to 2.11.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3f24-pcvm-5jqc is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-3f24-pcvm-5jqc (CC BY 4.0)
Frequently Asked Questions
Is GHSA-3f24-pcvm-5jqc in your dependencies?
Find it across Go, including transitive dependencies.