CVE-2026-33215 — nats-server
MEDIUMCVE-2026-33215 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in github.com/nats-io/nats-server/v2. A fix is available for github.com/nats-io/nats-server/v2 — see the affected versions and patch details below.
NATS is vulnerable to MQTT hijacking via Client ID
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33215.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/nats-io/nats-server/v2🐹github.com/nats-io/nats-server/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Background
NATS.io is a high performance open source pub-sub distributed communication technology, built for the cloud, on-premise, IoT, and edge computing.
The nats-server provides an MQTT client interface.
Problem Description
Sessions and Messages can by hijacked via MQTT Client ID malfeasance.
Affected Versions
Any version before v2.12.6 or v2.11.15
Workarounds
None.
Resources
- This document is canonically: https://advisories.nats.io/CVE/secnote-2026-06.txt
- GHSA advisory: https://github.com/nats-io/nats-server/security/advisories/GHSA-fcjp-h8cc-6879
- MITRE CVE entry: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2026-33215
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/nats-io/nats-server/v2 | all versions | 2.11.15go get github.com/nats-io/nats-server/v2@v2.11.15 |
| 🐹Go | github.com/nats-io/nats-server/v2 | ≥ 2.12.0-RC.1&&< 2.12.6 | 2.12.6go get github.com/nats-io/nats-server/v2@v2.12.6 |
Affected Products
nats-serverlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/nats-io/nats-server/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/nats-io/nats-server/v2 to 2.11.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33215 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Multicluster Global Hub 1.4.9 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779579439 | RHSA-2026:22347 |
| Multicluster Global Hub 1.6.5 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1780167118 | RHSA-2026:23345 |
| Red Hat multicluster global hub 1.5.3 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1778867753 | RHSA-2026:21769 |
Frequently Asked Questions
Is CVE-2026-33215 in your dependencies?
Find it across Go, including transitive dependencies.