CVE-2026-33217 — nats-server
HIGHCVE-2026-33217 is a high-severity (CVSS 7.1) CWE-863 vulnerability in github.com/nats-io/nats-server/v2. A fix is available for github.com/nats-io/nats-server/v2 — see the affected versions and patch details below.
NATS allows MQTT clients to bypass ACL checks
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33217.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/nats-io/nats-server/v2🐹github.com/nats-io/nats-server/v2🐹github.com/nats-io/nats-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Background
NATS.io is a high performance open source pub-sub distributed communication technology, built for the cloud, on-premise, IoT, and edge computing.
The nats-server provides an MQTT client interface.
Problem Description
When using ACLs on message subjects, these ACLs were not applied in the $MQTT.> namespace, allowing MQTT clients to bypass ACL checks for MQTT subjects.
Affected Versions
Any version before v2.12.6 or v2.11.15
Workarounds
None.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/nats-io/nats-server/v2 | all versions | 2.11.15go get github.com/nats-io/nats-server/v2@v2.11.15 |
| 🐹Go | github.com/nats-io/nats-server/v2 | ≥ 2.12.0-RC.1&&< 2.12.6 | 2.12.6go get github.com/nats-io/nats-server/v2@v2.12.6 |
| 🐹Go | github.com/nats-io/nats-server | all versions | No fix |
Affected Products
nats-serverlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/nats-io/nats-server/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/nats-io/nats-server/v2 to 2.11.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33217 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-33217 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Multicluster Global Hub 1.4.9 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779579439 | RHSA-2026:22347 |
| Multicluster Global Hub 1.6.5 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1780167118 | RHSA-2026:23345 |
| Red Hat multicluster global hub 1.5.3 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1778867753 | RHSA-2026:21769 |
Frequently Asked Questions
Is CVE-2026-33217 in your dependencies?
Find it across Go, including transitive dependencies.