NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

@electron/packager's build process memory potentially leaked into final executableGHSA-34h3-8mw4-qw57

HIGHFix: electron/packager@d421d4b

GHSA-34h3-8mw4-qw57 is a high-severity (CVSS 7.5) CWE-402 vulnerability in @electron/packager. A fix is available for @electron/packager — see the affected versions and patch details below.

Also known asCVE-2024-29900
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-34h3-8mw4-qw57.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.38%0.76%1.13%0.4%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

19other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@electron/packagernpm
1.8Mdownloads / week

Description

Electron Packager bundles Electron-based application source code with a renamed Electron executable and supporting files into folders ready for distribution. A random segment of ~1-10kb of Node.js heap memory allocated either side of a known buffer will be leaked into the final executable. This memory could contain sensitive information such as environment variables, secrets files, etc. This issue is patched in 18.3.1.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@electron/packager≥ 18.3.0&&< 18.3.118.3.1npm install @electron/packager@18.3.1

Affected Products

1 product · 1 configurations
Application
packageropenjsf
1 version
18.3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @electron/packager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @electron/packager to 18.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-34h3-8mw4-qw57 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact A random segment of ~1-10kb of Node.js heap memory allocated either side of a known buffer will be leaked into the final executable. This memory _could_ contain sensitive information such as environment variables, secrets files, etc. ### Patches This issue is patched in 18.3.1 ### Workarounds No workarounds, please update to a patched version of `@electron/packager` immediately if impacated.
O3 Security · Impact-Aware SCA

Is GHSA-34h3-8mw4-qw57 in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-34h3-8mw4-qw57: Fixed in 18.3.1 (High 7.5)