CVE-2021-31407 is a high-severity (CVSS 7.5) CWE-402 vulnerability in com.vaadin:flow-server. A fix is available for com.vaadin:flow-server — see the affected versions and patch details below.
OSGi applications using Vaadin 12-14 and 19 vulnerable to server classes and resources exposure
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2021-31407 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 395,492 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
com.vaadin:flow-server☕com.vaadin:flow-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.vaadin:flow-server | ≥ 1.2.0&&< 2.4.8 | 2.4.8com.vaadin:flow-server:2.4.8 |
| ☕Maven | com.vaadin:flow-server | ≥ 6.0.0&&< 6.0.1 | 6.0.1com.vaadin:flow-server:6.0.1 |
Affected Products
flowvaadinvaadinvaadinDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.vaadin:flow-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.vaadin:flow-server to 2.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-31407 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-31407 in your dependencies?
Find it across Maven, including transitive dependencies.