CVE-2023-25499 is a medium-severity (CVSS 5.7) Information Exposure vulnerability in com.vaadin:vaadin. A fix is available for com.vaadin:vaadin — see the affected versions and patch details below.
Possible information disclosure in non visible components
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-25499.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.vaadin:vaadin☕com.vaadin:vaadin☕com.vaadin:vaadin☕com.vaadin:vaadin☕com.vaadin:vaadin☕com.vaadin:flow-server☕com.vaadin:flow-server☕com.vaadin:flow-server+3 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Description
When adding non-visible components to the UI in server side, content is sent to the browser in Vaadin 10.0.0 through 10.0.22, 11.0.0 through 14.10.0, 15.0.0 through 22.0.28, 23.0.0 through 23.3.12, 24.0.0 through 24.0.5 and 24.1.0.alpha1 to 24.1.0.beta1, resulting in potential information disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.vaadin:vaadin | ≥ 10.0.0&&< 10.0.23 | 10.0.23com.vaadin:vaadin:10.0.23 |
| ☕Maven | com.vaadin:vaadin | ≥ 11.0.0&&< 14.10.1 | 14.10.1com.vaadin:vaadin:14.10.1 |
| ☕Maven | com.vaadin:vaadin | ≥ 23.0.0&&< 23.3.13 | 23.3.13com.vaadin:vaadin:23.3.13 |
| ☕Maven | com.vaadin:vaadin | ≥ 24.0.0&&< 24.0.6 | 24.0.6com.vaadin:vaadin:24.0.6 |
| ☕Maven | com.vaadin:vaadin | ≥ 24.1.0.alpha1&&< 24.1.0 | 24.1.0com.vaadin:vaadin:24.1.0 |
| ☕Maven | com.vaadin:flow-server | ≥ 1.0.0&&< 1.0.20 | 1.0.20com.vaadin:flow-server:1.0.20 |
Affected Products
vaadinvaadinDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.vaadin:vaadin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.vaadin:vaadin to 10.0.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-25499 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2023-25499 in your dependencies?
Find it across Maven, including transitive dependencies.