NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Weak JSON Web Token in yapi-vendorGHSA-2h3h-vw8r-82rp

MEDIUM

GHSA-2h3h-vw8r-82rp is a medium-severity (CVSS 5.1) Insufficient Random Values vulnerability in yapi-vendor. A fix is available for yapi-vendor — see the affected versions and patch details below.

Also known asCVE-2021-27884
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs27th percentile — riskier than 27% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
yapi-vendornpm
440downloads / week

Description

Weak JSON Web Token (JWT) signing secret generation in YMFE YApi through 1.9.2 allows recreation of other users' JWT tokens. This occurs because Math.random in Node.js is used as a source of randomness in jwt signing. Math.random does not provide cryptographically secure random numbers. This has been patched in version 1.9.3.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmyapi-vendorall versions1.9.3npm install yapi-vendor@1.9.3

Affected Products

1 product · 1 configurations
Application
yapiymfe
≤ 1.9.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yapi-vendor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update yapi-vendor to 1.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2h3h-vw8r-82rp is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Weak JSON Web Token (JWT) signing secret generation in YMFE YApi through 1.9.2 allows recreation of other users' JWT tokens. This occurs because Math.random in Node.js is used as a source of randomness in jwt signing. Math.random does not provide cryptographically secure random numbers. This has been patched in version 1.9.3.
O3 Security · Impact-Aware SCA

Is GHSA-2h3h-vw8r-82rp in your dependencies?

Find it across npm, including transitive dependencies.

Weak JSON Web Token in yapi-vendor (Medium 5.1)