CVE-2022-31008 is a medium-severity (CVSS 5.5) Insufficient Random Values vulnerability in rabbit_common. A fix is available for rabbit_common — see the affected versions and patch details below.
Predictable credential obfuscation seed value used in rabbitmq-server
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31008.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2022-31008 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 395,249 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
rabbit_common💧rabbit_common💧rabbit_commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Shovel and Federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret.
This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log.
Patched versions correctly use a cluster-wide secret for that purpose.
Patches
Patched versions:
3.10.23.9.183.8.32
Workarounds
Disable Shovel and Federation plugins.
Credits
RabbitMQ core team would like to thank Lajos @luos Gerecs and Anh Nguyen from Erlang Solutions for responsibly disclosing and working with us on a patch for this vulnerability.
For more information
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💧Hex | rabbit_common | ≥ 3.10.0&&< 3.10.2 | 3.10.2mix deps.update rabbit_common |
| 💧Hex | rabbit_common | ≥ 3.9.0&&< 3.9.18 | 3.9.18mix deps.update rabbit_common |
| 💧Hex | rabbit_common | ≥ 3.8.0&&< 3.8.32 | 3.8.32mix deps.update rabbit_common |
Affected Products
rabbitmq serverbroadcomrabbitmqvmwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rabbit_common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rabbit_common to 3.10.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31008 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-31008 in your dependencies?
Find it across Hex, including transitive dependencies.