NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2018-17574 — yapi-vendor

MEDIUM

CVE-2018-17574 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in yapi-vendor. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for yapi-vendor — see the affected versions and patch details below.

Cross-site Scripting in yapi-vendor

Also known asGHSA-5xgh-643p-cp2g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.78%1.17%0.2%0.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
yapi-vendornpm
552downloads / week

Description

An issue was discovered in YMFE YApi 1.3.23. There is stored XSS in the name field of a project.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmyapi-vendorall versions1.3.23npm install yapi-vendor@1.3.23

Affected Products

1 product · 1 configurations
Application
yapiymfe
1 version
1.3.22
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yapi-vendor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update yapi-vendor to 1.3.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-17574 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in YMFE YApi 1.3.23. There is stored XSS in the name field of a project.
O3 Security · Impact-Aware SCA

Is CVE-2018-17574 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2018-17574: yapi-vendor XSS — Fixed in 1.3.23