NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

Phusion Passenger denial of serviceGHSA-2cj2-qqxj-5m3r

MEDIUMFix: phusion/passenger@bb15591

GHSA-2cj2-qqxj-5m3r is a medium-severity (CVSS 5.3) CWE-908 vulnerability in passenger. A fix is available for passenger — see the affected versions and patch details below.

Also known asBIT-passenger-2025-26803BIT-passenger-apache-module-2025-26803BIT-passenger-nginx-module-2025-26803CVE-2025-26803
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-2cj2-qqxj-5m3r.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.75%1.12%0.3%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎passenger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspassenger≥ 6.0.21&&< 6.0.266.0.26bundle update passenger --conservative

Affected Products

1 product · 1 configurations
Application
passengerphusion
≥ 6.0.21 && < 6.0.26
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passenger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update passenger to 6.0.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2cj2-qqxj-5m3r is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.
O3 Security · Impact-Aware SCA

Is GHSA-2cj2-qqxj-5m3r in your dependencies?

Find it across RubyGems, including transitive dependencies.

Phusion Passenger denial of service (Medium 5.3)