NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2018-12026 — passenger

CRITICALFix: phusion/passenger@fd3717a

CVE-2018-12026 is a critical-severity (CVSS 9.8) CWE-59 vulnerability in passenger. A fix is available for passenger — see the affected versions and patch details below.

Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability

Also known asGHSA-7cv3-gvmc-8mq5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.62%1.23%1.84%2.45%1.1%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎passenger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

During the spawning of a malicious Passenger-managed application, SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows such applications to replace key files or directories in the spawning communication directory with symlinks. This then could result in arbitrary reads and writes, which in turn can result in information disclosure and privilege escalation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspassenger≥ 5.3.0&&< 5.3.25.3.2bundle update passenger --conservative

Affected Products

1 product · 1 configurations
Application
passengerphusion
≥ 5.3.0 && < 5.3.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passenger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update passenger to 5.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-12026 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

During the spawning of a malicious Passenger-managed application, SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows such applications to replace key files or directories in the spawning communication directory with symlinks. This then could result in arbitrary reads and writes, which in turn can result in information disclosure and privilege escalation.
O3 Security · Impact-Aware SCA

Is CVE-2018-12026 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2018-12026: passenger PrivEsc — Fixed in 5.3.2