NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2012-6135 — passenger

HIGHFix: phusion/passenger@8c6693e

CVE-2012-6135 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in passenger. A fix is available for passenger — see the affected versions and patch details below.

RubyGems passenger gem allows remote attackers to delete files

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.77%1.45%2.13%2.81%1.3%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎passenger

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process.

Affects both open source and Enterprise versions (4.0.0.beta1, 4.0.0.beta2).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspassengerall versions4.0.0.rc4bundle update passenger --conservative

Affected Products

2 products · 3 configurations
Application
passengerphusion
1 version
4.0.0
Application
openshiftredhat
1 version
1.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passenger, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update passenger to 4.0.0.rc4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-6135 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

RubyGems passenger 4.0.0 betas 1 and 2 allows remote attackers to delete arbitrary files during the startup process. Affects both open source and Enterprise versions (4.0.0.beta1, 4.0.0.beta2).
O3 Security · Impact-Aware SCA

Is CVE-2012-6135 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2012-6135: passenger — Fixed in 4.0.0.rc4