CVE-2026-50166 — kuma
Fix: kumahq/kuma@2d0fb38CVE-2026-50166 is a CWE-295 vulnerability in github.com/kumahq/kuma/v2. A fix is available for github.com/kumahq/kuma/v2 — see the affected versions and patch details below.
Kuma: kumactl connects to control plane without verifying TLS certificate when no CA is configured
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-50166.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
github.com/kumahq/kuma/v2🐹github.com/kumahq/kuma/v2🐹github.com/kumahq/kuma/v2🐹github.com/kumahq/kuma/v2🐹github.com/kumahq/kuma/v2🐹github.com/kumahq/kumaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
When an operator adds an HTTPS control plane profile to kumactl without providing a CA certificate, kumactl disables TLS verification and sends API tokens over the unverified connection
Impact
An attacker on the network path between the operator and the control plane can intercept user or admin API tokens and then act against the control plane as that user
Affected configurations
kumactlprofiles manually added against an HTTPS control plane endpoint without--ca-cert-file
Not affected
- The default local profile, which uses plain HTTP
Workarounds
When adding an HTTPS control plane profile to kumactl, always pass --ca-cert-file pointing at the control plane's serving CA. Alternatively, terminate the control plane behind a publicly trusted certificate; the patched releases will verify successfully against the operating system trust store with no further configuration
Resources
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/kumahq/kuma/v2 | all versions | 2.7.26go get github.com/kumahq/kuma/v2@v2.7.26 |
| 🐹Go | github.com/kumahq/kuma/v2 | ≥ 2.8.0&&< 2.9.16 | 2.9.16go get github.com/kumahq/kuma/v2@v2.9.16 |
| 🐹Go | github.com/kumahq/kuma/v2 | ≥ 2.10.0&&< 2.11.14 | 2.11.14go get github.com/kumahq/kuma/v2@v2.11.14 |
| 🐹Go | github.com/kumahq/kuma/v2 | ≥ 2.12.0&&< 2.12.11 | 2.12.11go get github.com/kumahq/kuma/v2@v2.12.11 |
| 🐹Go | github.com/kumahq/kuma/v2 | ≥ 2.13.0&&< 2.13.7 | 2.13.7go get github.com/kumahq/kuma/v2@v2.13.7 |
| 🐹Go | github.com/kumahq/kuma | all versions | No fix |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kumahq/kuma/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/kumahq/kuma/v2 to 2.7.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-50166 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-50166 in your dependencies?
Find it across Go, including transitive dependencies.