GHSA-9wmc-rg4h-28wv is a high-severity (CVSS 7.5) vulnerability in github.com/kumahq/kuma. A fix is available for github.com/kumahq/kuma — see the affected versions and patch details below.
Real-World Exposure
github.com/kumahq/kuma🐹github.com/kumahq/kuma🐹github.com/kumahq/kuma🐹github.com/kumahq/kuma🐹github.com/kumahq/kumaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Envoy and Go HTTP/2 protocol stack is vulnerable to the "Rapid Reset" class of exploits, which send a sequence of HEADERS frames optionally followed by RST_STREAM frames.
This can be exercised if you use the builtin gateway and receive untrusted http2 traffic.
Patches
https://github.com/kumahq/kuma/pull/8023 https://github.com/kumahq/kuma/pull/8001 https://github.com/kumahq/kuma/pull/8034
Workarounds
Disable http2 on the gateway listener with a MeshProxyPatch or ProxyTemplate.
References
https://github.com/advisories/GHSA-qppj-fm5r-hxr3 https://github.com/golang/go/issues/63417 https://github.com/envoyproxy/envoy/security/advisories/GHSA-jhv4-f7mr-xx76 https://cloud.google.com/blog/products/identity-security/how-it-works-the-novel-http2-rapid-reset-ddos-attack https://www.nginx.com/blog/http-2-rapid-reset-attack-impacting-f5-nginx-products/?sf269548684=1 https://www.envoyproxy.io/docs/envoy/latest/configuration/best_practices/edge
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/kumahq/kuma | ≥ 2.4.0&&< 2.4.3 | 2.4.3go get github.com/kumahq/kuma@v2.4.3 |
| 🐹Go | github.com/kumahq/kuma | ≥ 2.3.0&&< 2.3.3 | 2.3.3go get github.com/kumahq/kuma@v2.3.3 |
| 🐹Go | github.com/kumahq/kuma | ≥ 2.2.0&&< 2.2.4 | 2.2.4go get github.com/kumahq/kuma@v2.2.4 |
| 🐹Go | github.com/kumahq/kuma | ≥ 2.1.0&&< 2.1.8 | 2.1.8go get github.com/kumahq/kuma@v2.1.8 |
| 🐹Go | github.com/kumahq/kuma | all versions | 2.0.8go get github.com/kumahq/kuma@v2.0.8 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kumahq/kuma, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/kumahq/kuma to 2.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9wmc-rg4h-28wv is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-9wmc-rg4h-28wv in your dependencies?
Find it across Go, including transitive dependencies.