CVE-2026-44405 is a low-severity (CVSS 3.4) Broken Cryptographic Algorithm vulnerability in paramiko. A fix is available for paramiko — see the affected versions and patch details below.
Paramiko rsakey.py allows the SHA-1 algorithm
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-44405.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
paramikoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Paramiko through 4.0.0 before a448945, rsakey.py allows the SHA-1 algorithm.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | paramiko | all versions | 5.0.0pip install --upgrade 'paramiko==5.0.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paramiko, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update paramiko to 5.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-44405 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-44405 in your dependencies?
Find it across PyPI, including transitive dependencies.