CVE-2018-7750 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in paramiko. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for paramiko — see the affected versions and patch details below.
Paramiko not properly checking authentication before processing other requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
paramiko🐍paramiko🐍paramiko🐍paramiko🐍paramiko🐍paramiko🐍paramikoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before 1.18.5, 2.0.x before 2.0.8, 2.1.x before 2.1.5, 2.2.x before 2.2.3, 2.3.x before 2.3.2, and 2.4.x before 2.4.1 does not properly check whether authentication is completed before processing other requests, as demonstrated by channel-open. A customized SSH client can simply skip the authentication step.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | paramiko | ≥ 2.0.0&&< 2.0.8 | 2.0.8pip install --upgrade 'paramiko==2.0.8' |
| 🐍PyPI | paramiko | ≥ 2.1.0&&< 2.1.5 | 2.1.5pip install --upgrade 'paramiko==2.1.5' |
| 🐍PyPI | paramiko | ≥ 2.2.0&&< 2.2.3 | 2.2.3pip install --upgrade 'paramiko==2.2.3' |
| 🐍PyPI | paramiko | ≥ 2.3.0&&< 2.3.2 | 2.3.2pip install --upgrade 'paramiko==2.3.2' |
| 🐍PyPI | paramiko | ≥ 2.4.0&&< 2.4.1 | 2.4.1pip install --upgrade 'paramiko==2.4.1' |
| 🐍PyPI | paramiko | ≥ 1.18.0&&< 1.18.5 | 1.18.5pip install --upgrade 'paramiko==1.18.5' |
Affected Products
debian linuxdebianparamikoparamikoansible engineredhatcloudformsredhatenterprise linux desktopredhatenterprise linux serverredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Paramiko 2.4.1 - Authentication Bypass
by Adam Brown · Oct 29, 2018
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paramiko, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update paramiko to 2.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-7750 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This flaw is a user authentication bypass in the SSH Server functionality of paramiko (normally used by subclassing `paramiko.ServerInterface`). Where paramiko is used only for its client-side functionality (e.g. `paramiko.SSHClient`), the vulnerability is not exposed and thus cannot be exploited. The following Red…
| Product | Fixed in | Advisory |
|---|---|---|
| CloudForms Management Engine 5.8 | ansible-0:2.4.4.0-1.el7ae | RHSA-2018:1972 |
| CloudForms Management Engine 5.9 | ansible-0:2.4.4.0-1.el7ae | RHSA-2018:1328 |
| Red Hat Ansible Engine 2.4 for RHEL 7 | python-paramiko-0:2.1.1-4.el7 | RHSA-2018:1213 |
| Red Hat Ansible Engine 2 for RHEL 7 | python-paramiko-0:2.1.1-4.el7 | RHSA-2018:0646 |
| Red Hat Enterprise Linux 6 | python-paramiko-0:1.7.5-4.el6_9 | RHSA-2018:1124 |
| Red Hat Enterprise Linux 6.4 Advanced Update Support | python-paramiko-0:1.7.5-4.el6_4 | RHSA-2018:1125 |
| Red Hat Enterprise Linux 7 Extras | python-paramiko-0:2.1.1-4.el7 | RHSA-2018:0591 |
| Red Hat Virtualization 4 for Red Hat Enterprise Linux 7 | python-paramiko-0:2.1.1-4.el7 | RHSA-2018:1274 |
Frequently Asked Questions
Is CVE-2018-7750 in your dependencies?
Find it across PyPI, including transitive dependencies.