NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2008-0299 — paramiko

MEDIUM

CVE-2008-0299 is a medium-severity (CVSS 6.5) vulnerability in paramiko. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for paramiko — see the affected versions and patch details below.

Paramiko Unsafe randomness usage may allow access to sensitive information

Also known asGHSA-wqmm-q65g-2hqrPYSEC-2008-8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.82%1.25%1.69%2.12%1.3%1.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍paramiko

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

common.py in Paramiko 1.7.1 and earlier, when using threads or forked processes, does not properly use RandomPool, which allows one session to obtain sensitive information from another session by predicting the state of the pool.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIparamikoall versions1.7.1-3pip install --upgrade 'paramiko==1.7.1-3'

Affected Products

1 product · 1 configurations
Application
paramikopython_software_foundation
1 version
1.7.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paramiko, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update paramiko to 1.7.1-3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2008-0299 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

common.py in Paramiko 1.7.1 and earlier, when using threads or forked processes, does not properly use RandomPool, which allows one session to obtain sensitive information from another session by predicting the state of the pool.
O3 Security · Impact-Aware SCA

Is CVE-2008-0299 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2008-0299: paramiko Info Disclosure — Fixed in 1.7.1-3