CVE-2026-44167 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in phpseclib/phpseclib. A fix is available for phpseclib/phpseclib — see the affected versions and patch details below.
phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-44167.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpseclib/phpseclib🐘phpseclib/phpseclib🐘phpseclib/phpseclibReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpseclib/phpseclib | ≥ 0.1.1&&< 1.0.29 | 1.0.29composer require phpseclib/phpseclib:^1.0.29 |
| 🐘Packagist | phpseclib/phpseclib | ≥ 2.0.0&&< 2.0.54 | 2.0.54composer require phpseclib/phpseclib:^2.0.54 |
| 🐘Packagist | phpseclib/phpseclib | ≥ 3.0.0&&< 3.0.52 | 3.0.52composer require phpseclib/phpseclib:^3.0.52 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpseclib/phpseclib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpseclib/phpseclib to 1.0.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-44167 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2026-44167 in your dependencies?
Find it across Packagist, including transitive dependencies.