CVE-2023-52892 is a high-severity (CVSS 7.5) CWE-436 vulnerability in phpseclib/phpseclib. A fix is available for phpseclib/phpseclib — see the affected versions and patch details below.
Name confusion in x509 Subject Alternative Name fields
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-52892.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpseclib/phpseclib🐘phpseclib/phpseclib🐘phpseclib/phpseclibReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In phpseclib before 1.0.22, 2.x before 2.0.46, and 3.x before 3.0.33, some characters in Subject Alternative Name fields in TLS certificates are incorrectly allowed to have a special meaning in regular expressions (such as a + wildcard), leading to name confusion in X.509 certificate host verification.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpseclib/phpseclib | all versions | 1.0.22composer require phpseclib/phpseclib:^1.0.22 |
| 🐘Packagist | phpseclib/phpseclib | ≥ 2.0.0&&< 2.0.46 | 2.0.46composer require phpseclib/phpseclib:^2.0.46 |
| 🐘Packagist | phpseclib/phpseclib | ≥ 3.0.0&&< 3.0.33 | 3.0.33composer require phpseclib/phpseclib:^3.0.33 |
Affected Products
phpseclibphpseclibDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpseclib/phpseclib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpseclib/phpseclib to 1.0.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-52892 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-52892 in your dependencies?
Find it across Packagist, including transitive dependencies.