NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

phpseclib has a CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()GHSA-3qpq-r242-jqj7

HIGHFix: phpseclib/phpseclib@d53d202

GHSA-3qpq-r242-jqj7 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in phpseclib/phpseclib. A fix is available for phpseclib/phpseclib — see the affected versions and patch details below.

Also known asCVE-2026-44167
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-3qpq-r242-jqj7.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs10th percentile — riskier than 10% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.0%0.2%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpseclib/phpseclib🐘phpseclib/phpseclib🐘phpseclib/phpseclib

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc)

Patches

https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc

Workarounds

No.

References

https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpseclib/phpseclib≥ 0.1.1&&< 1.0.291.0.29composer require phpseclib/phpseclib:^1.0.29
🐘Packagistphpseclib/phpseclib≥ 2.0.0&&< 2.0.542.0.54composer require phpseclib/phpseclib:^2.0.54
🐘Packagistphpseclib/phpseclib≥ 3.0.0&&< 3.0.523.0.52composer require phpseclib/phpseclib:^3.0.52

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpseclib/phpseclib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpseclib/phpseclib to 1.0.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3qpq-r242-jqj7 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact Anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc) ### Patches https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc ### Workarounds No. ### References https://github.com/phpseclib/phpseclib/commit/d53d2021bcb9f6a04d5d44ec99e6bbef219a71bc
O3 Security · Impact-Aware SCA

Is GHSA-3qpq-r242-jqj7 in your dependencies?

Find it across Packagist, including transitive dependencies.

phpseclib has a CVE-2024-27355 mitigation bypass — OID…