CVE-2026-42997 — ironic-python-agent
HIGHCVE-2026-42997 is a high-severity (CVSS 7.7) CWE-669 vulnerability in ironic-python-agent. A fix is available for ironic-python-agent — see the affected versions and patch details below.
OpenStack Ironic has an Incorrect Resource Transfer Between Spheres
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42997.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ironic-python-agent🐍ironic-python-agent🐍ironic-python-agent🐍ironic-python-agentReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in idrac in OpenStack Ironic before 35.0.1. During import, a user invoking molds can request authorization to be sent to a remote endpoint. The credential forwarded is a time-limited Keystone token (which provides access to all OpenStack services Ironic is authorized for); or basic credentials configured for molds storage. The fixed versions are 26.1.6, 29.0.5, 32.0.1, and 35.0.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | ironic-python-agent | ≥ 33.0.0&&< 35.0.1 | 35.0.1pip install --upgrade 'ironic-python-agent==35.0.1' |
| 🐍PyPI | ironic-python-agent | ≥ 30.0.0&&< 32.0.1 | 32.0.1pip install --upgrade 'ironic-python-agent==32.0.1' |
| 🐍PyPI | ironic-python-agent | ≥ 27.0.0&&< 29.0.5 | 29.0.5pip install --upgrade 'ironic-python-agent==29.0.5' |
| 🐍PyPI | ironic-python-agent | all versions | 26.1.6pip install --upgrade 'ironic-python-agent==26.1.6' |
Affected Products
ironicopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ironic-python-agent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ironic-python-agent to 35.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-42997 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This IMPORTANT information disclosure vulnerability in OpenStack Ironic allows authenticated users to forward credentials to attacker-controlled endpoints during mold import. The scope is changed as disclosed credentials can access other OpenStack services. Impact is high confidentiality loss. Fixed in versions…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Services on OpenShift 18.0 | openstack-ironic-1:21.4.5-18.0.20260616204937.9213ccd.el9ost | RHSA-2026:39811 |
Frequently Asked Questions
Is CVE-2026-42997 in your dependencies?
Find it across PyPI, including transitive dependencies.