CVE-2026-35540 is a medium-severity (CVSS 5.4) CWE-669 vulnerability in roundcube/roundcubemail. A fix is available for roundcube/roundcubemail — see the affected versions and patch details below.
Roundcube Webmail: Insufficient CSS sanitization in HTML e-mail messages
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-35540.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
roundcube/roundcubemailReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Roundcube Webmail 1.6.0 before 1.6.14. Insufficient Cascading Style Sheets (CSS) sanitization in HTML e-mail messages may lead to SSRF or Information Disclosure, e.g., if stylesheet links point to local network hosts.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | roundcube/roundcubemail | ≥ 1.7-beta&&< 1.7-rc5 | 1.7-rc5composer require roundcube/roundcubemail:^1.7-rc5 |
Affected Products
webmailroundcubeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for roundcube/roundcubemail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update roundcube/roundcubemail to 1.7-rc5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-35540 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2026-35540 in your dependencies?
Find it across Packagist, including transitive dependencies.