NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

OpenStack Ironic has an Incorrect Resource Transfer Between SpheresGHSA-54w4-233h-x86g

HIGH

GHSA-54w4-233h-x86g is a high-severity (CVSS 7.7) CWE-669 vulnerability in ironic-python-agent. A fix is available for ironic-python-agent — see the affected versions and patch details below.

Also known asCVE-2026-42997PYSEC-2026-2526
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-54w4-233h-x86g.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.35%0.70%1.04%0.0%0.4%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐍ironic-python-agent🐍ironic-python-agent🐍ironic-python-agent🐍ironic-python-agent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in idrac in OpenStack Ironic before 35.0.1. During import, a user invoking molds can request authorization to be sent to a remote endpoint. The credential forwarded is a time-limited Keystone token (which provides access to all OpenStack services Ironic is authorized for); or basic credentials configured for molds storage. The fixed versions are 26.1.6, 29.0.5, 32.0.1, and 35.0.1.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIironic-python-agent≥ 33.0.0&&< 35.0.135.0.1pip install --upgrade 'ironic-python-agent==35.0.1'
🐍PyPIironic-python-agent≥ 30.0.0&&< 32.0.132.0.1pip install --upgrade 'ironic-python-agent==32.0.1'
🐍PyPIironic-python-agent≥ 27.0.0&&< 29.0.529.0.5pip install --upgrade 'ironic-python-agent==29.0.5'
🐍PyPIironic-python-agentall versions26.1.6pip install --upgrade 'ironic-python-agent==26.1.6'

Affected Products

1 product · 4 configurations
Application
ironicopenstack
≥ 33.0.0 && < 35.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ironic-python-agent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ironic-python-agent to 35.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-54w4-233h-x86g is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This IMPORTANT information disclosure vulnerability in OpenStack Ironic allows authenticated users to forward credentials to attacker-controlled endpoints during mold import. The scope is changed as disclosed credentials can access other OpenStack services. Impact is high confidentiality loss. Fixed in versions…

ProductFixed inAdvisory
Red Hat OpenStack Services on OpenShift 18.0openstack-ironic-1:21.4.5-18.0.20260616204937.9213ccd.el9ostRHSA-2026:39811

Frequently Asked Questions

An issue was discovered in idrac in OpenStack Ironic before 35.0.1. During import, a user invoking molds can request authorization to be sent to a remote endpoint. The credential forwarded is a time-limited Keystone token (which provides access to all OpenStack services Ironic is authorized for); or basic credentials configured for molds storage. The fixed versions are 26.1.6, 29.0.5, 32.0.1, and 35.0.1.
O3 Security · Impact-Aware SCA

Is GHSA-54w4-233h-x86g in your dependencies?

Find it across PyPI, including transitive dependencies.

OpenStack Ironic has an Incorrect Resource Transfer…