NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2026-42150 — wlc

MEDIUMFix: WeblateOrg/wlc@0f3e58f

CVE-2026-42150 is a medium-severity (CVSS 5.1) Cross-site Scripting (XSS) vulnerability in wlc. A fix is available for wlc — see the affected versions and patch details below.

wlc: print_html outputs API data without HTML escaping, enabling stored XSS

Also known asGHSA-gx2m-mcc2-r4p3PYSEC-2026-2321
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42150.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs7th percentile — riskier than 7% of all scored CVEsHighest risk
0.00%0.27%0.54%0.80%0.0%0.2%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍wlc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser.

Patches

Workarounds

The only vulnerable code path is HTML output which is opt-in.

References

Weblate thanks @fg0x0 for reporting this on GitHub.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIwlcall versions2.0.0pip install --upgrade 'wlc==2.0.0'

Affected Products

1 product · 1 configurations
Application
wlcweblate
< 2.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wlc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wlc to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-42150 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact The HTML output format in wlc embeds API response data into HTML without escaping, allowing cross-site scripting when the output is rendered in a browser. ### Patches * https://github.com/WeblateOrg/wlc/pull/1327 ### Workarounds The only vulnerable code path is HTML output which is opt-in. ### References Weblate thanks @fg0x0 for reporting this on GitHub.
O3 Security · Impact-Aware SCA

Is CVE-2026-42150 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-42150: wlc XSS — Fixed in 2.0.0