NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2026-23535 — wlc

HIGHFix: WeblateOrg/wlc@216e691

CVE-2026-23535 is a high-severity (CVSS 8) Path Traversal vulnerability in wlc. A fix is available for wlc — see the affected versions and patch details below.

wlc Path traversal: Unsanitized API slugs in download command

Also known asGHSA-mmwx-79f6-67jgPYSEC-2026-2053
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-23535.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.30%0.60%0.89%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍wlc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Multi-translation download could write to an arbitrary location when instructed by a crafted server.

Patches

Workarounds

Do not use wlc download with untrusted servers.

References

This issue was reported to us by wh1zee via HackerOne.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIwlcall versions1.17.2pip install --upgrade 'wlc==1.17.2'

Affected Products

1 product · 1 configurations
Application
wlcweblate
< 1.17.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wlc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wlc to 1.17.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-23535 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact Multi-translation download could write to an arbitrary location when instructed by a crafted server. ### Patches * https://github.com/WeblateOrg/wlc/pull/1128 ### Workarounds Do not use `wlc download` with untrusted servers. ### References This issue was reported to us by [wh1zee](https://hackerone.com/wh1zee) via HackerOne.
O3 Security · Impact-Aware SCA

Is CVE-2026-23535 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-23535: wlc — Fixed in 1.17.2