NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2026-34040 — moby

HIGHFix: moby/moby@e89edb1

CVE-2026-34040 is a high-severity (CVSS 8.8) CWE-288 vulnerability in github.com/moby/moby. A fix is available for github.com/moby/moby — see the affected versions and patch details below.

Moby: AuthZ plugin bypass with oversized request body

Also known asGHSA-x744-4wpc-v9h2GO-2026-4887
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-34040.

EPSS Exploitation Probability

via FIRST.org ↗
9.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.00%4.39%8.79%13.2%0.0%9.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/moby/moby🐹github.com/moby/moby/v2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ) under specific circumstances. The base likelihood of this being exploited is low.

This is an incomplete fix for CVE-2024-41110.

Impact

If you don't use AuthZ plugins, you are not affected.

Using a specially-crafted API request, an attacker could make the Docker daemon forward the request to an authorization plugin without the body. The authorization plugin may allow a request which it would have otherwise denied if the body had been forwarded to it.

Anyone who depends on authorization plugins that introspect the request body to make access control decisions is potentially impacted.

Workarounds

If unable to update immediately:

  • Avoid using AuthZ plugins that rely on request body inspection for security decisions.
  • Restrict access to the Docker API to trusted parties, following the principle of least privilege.

Credits

Resources

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/moby/mobyall versions29.3.1go get github.com/moby/moby@v29.3.1
🐹Gogithub.com/moby/moby/v2all versions2.0.0-beta.8go get github.com/moby/moby/v2@v2.0.0-beta.8

Affected Products

1 product · 1 configurations
Application
enginedocker
< 29.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/moby/moby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/moby/moby to 29.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-34040 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat rates this vulnerability as Moderate severity because exploitation requires existing access to the Docker daemon API and affects only non-default deployments configured with authorization plugins. Standard Red Hat environments do not deploy or rely on authorization plugins that inspect request payloads for…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for CVE-2026-34040 (CC BY 4.0)
ProductFixed inAdvisory
Multicluster Global Hub 1.4.9multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779579439RHSA-2026:22347
Multicluster Global Hub 1.4.9multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1788375682RHSA-2026:67516
Multicluster Global Hub 1.5.8multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1778867753RHSA-2026:21769
Multicluster Global Hub 1.5.8multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1789515639RHSA-2026:71597
Multicluster Global Hub 1.6.6multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1780167118RHSA-2026:23345
Multicluster Global Hub 1.6.6multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1790086248RHSA-2026:73419
Multicluster Global Hub 1.7.3multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779925273RHSA-2026:24503
Multicluster Global Hub 1.7.3multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1788376193RHSA-2026:67842

Frequently Asked Questions

## Summary A security vulnerability has been detected that allows attackers to bypass [authorization plugins (AuthZ)](https://docs.docker.com/engine/extend/plugins_authorization/) under specific circumstances. The base likelihood of this being exploited is low. This is an incomplete fix for [CVE-2024-41110](https://github.com/moby/moby/security/advisories/GHSA-v23v-6jw2-98fq). ## Impact **If you don't use AuthZ plugins, you are not affected.** Using a specially-crafted API request, an attacker could make the Docker daemon forward the request to an authorization plugin without the body. Th
O3 Security · Impact-Aware SCA

Is CVE-2026-34040 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2026-34040: moby — Fixed in 29.3.1