NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2026-33997 — docker

MEDIUMFix: moby/moby@f4d6f25

CVE-2026-33997 is a medium-severity (CVSS 6.8) CWE-193 vulnerability in github.com/docker/docker. A fix is available for github.com/docker/docker — see the affected versions and patch details below.

Moby: Off-by-one error in plugin privilege validation

Also known asGHSA-pxq6-2prw-chj9GO-2026-4883
Published
Updated
Affected
3 pkgs
Patched
1 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33997.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs34th percentile — riskier than 34% of all scored CVEsHighest risk
0.00%0.34%0.67%1.01%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/docker/docker🐹github.com/moby/moby/v2🐹github.com/moby/moby

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user.

Plugins that request exactly one privilege are also affected, because no comparison is performed at all.

Impact

If plugins are not in use, there is no impact.

When a plugin is installed, the daemon computes the privileges required by the plugin's configuration and compares them with the privileges approved during installation. A malicious plugin can exploit this bug so that the daemon accepts privileges that differ from what was intended to be approved.

Anyone who depends on the plugin installation approval flow as a meaningful security boundary is potentially impacted.

Depending on the privilege set involved, this may include highly sensitive plugin permissions such as broad device access.

For consideration: exploitation still requires a plugin to be installed from a malicious source, and Docker plugins are relatively uncommon. Docker Desktop also does not support plugins.

Workarounds

If unable to update immediately:

  • Do not install plugins from untrusted sources
  • Carefully review all privileges requested during docker plugin install
  • Restrict access to the Docker daemon to trusted parties, following the principle of least privilege
  • Avoid relying on plugin privilege approval as the only control boundary for sensitive environments

Credits

Affected Packages

3 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/docker/dockerall versionsNo fix
🐹Gogithub.com/moby/moby/v2all versions2.0.0-beta.8go get github.com/moby/moby/v2@v2.0.0-beta.8
🐹Gogithub.com/moby/mobyall versionsNo fix

Affected Products

1 product · 1 configurations
Application
enginedocker
< 29.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/docker/docker, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2026-33997; check the affected-versions list above or the advisory for the patched release of github.com/docker/docker, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

An important flaw in Moby, an open-source container framework, allows for a privilege validation bypass during `docker plugin install`. This issue stems from an error in the daemon's privilege comparison logic, which could lead to unauthorized privilege escalation for installed plugins. Red Hat products that leverage…

ProductFixed inAdvisory
Multicluster Global Hub 1.4.9multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779579439RHSA-2026:22347
Multicluster Global Hub 1.6.5multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1780167118RHSA-2026:23345
Red Hat multicluster global hub 1.5.3multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1778867753RHSA-2026:21769

Frequently Asked Questions

## Summary A security vulnerability has been detected that allows [plugins](https://docs.docker.com/engine/extend/legacy_plugins/) privilege validation to be bypassed during `docker plugin install`. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. ## Impact **If plugins are not in use, there is no impact.** When a plugin is installed, the daemon computes the privileges required
O3 Security · Impact-Aware SCA

Is CVE-2026-33997 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2026-33997: docker — Fixed in 2.0.0-beta.8