CVE-2024-36620 is a medium-severity (CVSS 6.5) NULL Pointer Dereference vulnerability in github.com/moby/moby. A fix is available for github.com/moby/moby — see the affected versions and patch details below.
NULL Pointer Dereference on moby image history
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-36620.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/moby/mobyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
moby v25.0.0 - v26.0.2 is vulnerable to NULL Pointer Dereference via daemon/images/image_history.go.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/moby/moby | ≥ 25.0.0&&< 26.1.0 | 26.1.0go get github.com/moby/moby@v26.1.0 |
Affected Products
mobymobyprojectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/moby/moby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/moby/moby to 26.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-36620 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-36620 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.16 | openshift4/ose-agent-installer-api-server-rhel9:v4.16.0-202503121138.p0.gef6fa80.assembly.stream.el9 | RHSA-2025:3301 |
| Red Hat OpenShift Container Platform 4.17 | openshift4/ose-agent-installer-api-server-rhel9:v4.17.0-202502172135.p0.g9145aec.assembly.stream.el9 | RHSA-2025:1703 |
Frequently Asked Questions
Is CVE-2024-36620 in your dependencies?
Find it across Go, including transitive dependencies.